summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2023-11-06 21:06:57 +0330
committerMohammadreza Abdollahzadeh2023-11-06 21:06:57 +0330
commite449e66ac0df5d3254149dbef1d893126e8e8250 (patch)
tree5c33d55af8500be893afa590c33a7b2edf3a68b1 /PKGBUILD
parent06de00e96e9872c0c349539384f73cf1c1403e73 (diff)
downloadaur-systemd-bootchart.tar.gz
upgpkg: systemd-bootchart 235-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e2174354178..b27916eb4091 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail.com>
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
-
pkgname=systemd-bootchart
-pkgver=234
+pkgver=235
pkgrel=1
pkgdesc='Systemd boot performance graphing tool.'
arch=('x86_64')
url='https://github.com/systemd/systemd-bootchart'
license=('GPL2' 'LGPL2.1')
depends=('libsystemd')
-makedepends=('docbook-xsl')
-source=("https://github.com/systemd/systemd-bootchart/releases/download/v${pkgver}/systemd-bootchart-${pkgver}.tar.xz")
-sha256sums=('74b7bcc385a9399cbc17aa86dd5f14425cd85140807f89b0b99008e843b8134b')
+makedepends=('docbook-xsl' 'intltool')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('42aa55fe1d3054ba3c119a4479929913445c48768eb1d36b13db8c6ad1889b81')
build() {
- cd "${srcdir}/systemd-bootchart-${pkgver}"
- ./configure --prefix=/usr --sysconfdir=/etc
+ cd "${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/lib CFLAGS='-g -O0 -ftrapv'
make
}
package() {
- cd "${srcdir}/systemd-bootchart-${pkgver}"
+ cd "${pkgname}-${pkgver}"
make install DESTDIR="${pkgdir}"
}
-# vim:set ts=4 sw=4:
+# vim:set ts=4 sw=4 et: