summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas DOREL2019-12-31 18:54:56 +0100
committerJonas DOREL2019-12-31 18:57:37 +0100
commit64ebc16775f7b95ea042d5d0aefa00b47f25467c (patch)
tree18310abfc2daad229b40ae7a3ab8fc15297f9ed0 /PKGBUILD
downloadaur-systemd-timer-pacman-download-updates-git.tar.gz
Initial PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26c2fa5fa3f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jonas DOREL <jonas at dorel dot me>
+pkgname=systemd-timer-pacman-download-updates-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Systemd timer to download packages updates"
+arch=('any')
+url="https://gitlab.com/jdorel-archlinux/systemd-pacman-download-updates"
+license=('GPL')
+depends=('systemd-service-pacman-download-updates')
+makedepends=('git')
+provides=('systemd-timer-pacman-download-updates')
+source=("${pkgname}::git+https://gitlab.com/jdorel-archlinux/systemd-pacman-download-updates")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ #printf "latest"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm 644 pacman-download-updates.timer "$pkgdir/usr/lib/systemd/system/pacman-download-updates.timer"
+}