summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Hebb2015-07-01 13:36:07 -0400
committerThomas Hebb2015-07-01 13:36:07 -0400
commit0915615a9ad3f5c7358be76cf9743c76412c1349 (patch)
tree2938c855018a0cf1b3e45777233c81caaf00dcf6 /PKGBUILD
downloadaur-systemd-xorg-launch-helper-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a305886f01f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Thomas Hebb <tommyhebb@gmail.com>
+# Contributor: Alucryd <alucryd at gmail dot com>
+
+pkgname=systemd-xorg-launch-helper-git
+pkgver=28
+pkgrel=1
+pkgdesc="A wrapper in C to make X.Org function as a proper systemd unit"
+arch=('i686' 'x86_64')
+url="https://github.com/sofar/xorg-launch-helper"
+license=('GPL2')
+depends=('systemd' 'xorg-server')
+makedepends=('git')
+provides=('xorg-launch-helper')
+conflicts=('xorg-launch-helper')
+source=('git+https://github.com/sofar/xorg-launch-helper.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd xorg-launch-helper
+
+ git rev-list --count HEAD
+}
+
+build () {
+ cd xorg-launch-helper
+
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd xorg-launch-helper
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: