summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCanas Simon2024-02-25 17:59:37 +0100
committerCanas Simon2024-02-25 17:59:37 +0100
commit122af25800effc90b30c91144ea162ac44964a5e (patch)
treef11d12a05932d8f9086c1ac0e891541e16033140 /PKGBUILD
parent8d44e275c04838f85788af55e7c651d253c70c05 (diff)
downloadaur-tacentview-git.tar.gz
Fixed the .desktop file being gone
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4c6bb1041e6..b05f4a3fe27b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=tacentview
pkgname=${_pkgname}-git
pkgver=1.0.43.9.gdfff366
-pkgrel=2
+pkgrel=3
pkgdesc="An image and texture viewer for tga, png, apng, exr, dds, ktx, ktx2, astc, pkm, qoi, gif, hdr, jpg, tif, ico, webp, and bmp files. Uses Dear ImGui, OpenGL and Tacent."
arch=('any')
url="https://github.com/bluescan/${_pkgname}"
@@ -34,15 +34,24 @@ build() {
}
package() {
+ DEB_TEMPLATE="${_pkgname}/Linux/deb_template/usr"
+
# Installing the program's binaries
- install -Dm755 build/ViewerInstall/${_pkgname} -t "${pkgdir}/usr/bin"
+ install -D -m755 build/ViewerInstall/${_pkgname} -t "${pkgdir}/usr/bin/"
# Installing the program's data
- install -Dm644 build/ViewerInstall/Data/* -t "${pkgdir}/usr/share/${_pkgname}/Data"
+ install -D -m644 build/ViewerInstall/Data/* -t "${pkgdir}/usr/share/${_pkgname}/Data/"
+
+ # Installing the desktop file
+ install -D -m644 ${DEB_TEMPLATE}/share/applications/* -t "${pkgdir}/usr/share/applications/"
# Installing the docs
- install -Dm644 ${_pkgname}/docs/* -t "${pkgdir}/usr/share/doc/${_pkgname}"
+ install -D -m644 ${_pkgname}/docs/* -t "${pkgdir}/usr/share/doc/${_pkgname}"
# Installing the licenses
- install -Dm644 ${_pkgname}/LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ install -D -m644 ${_pkgname}/LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}/"
+
+ # Installing the icon files (quick and dirty solution due to the complex structure)
+ cd ${DEB_TEMPLATE}/share/icons/
+ find ./* -type f -exec install -D -m644 "{}" "${pkgdir}/usr/share/icons/{}" \;
}