summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2020-02-22 02:06:01 +0100
committerNarrat2020-02-22 02:06:01 +0100
commit4fd3563be772faca2a0e81c702bf08f46c0b33fd (patch)
tree4eb6f0ea5b302de8da43bec7dbae8cb894b0124d /PKGBUILD
parent1f3b8e18851d4f13717a1bbf4b5b84e2e51ede2b (diff)
downloadaur-tako-git.tar.gz
update repo url
and the new repo doesn't contain tags, so change the pkgver()
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da7320025e1c..da333274221c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,33 @@
-# Maintainer: jdkaplan <jdkaplan@metagram.net>
+# Contributor: Lex Black <autumn-wind@web.de>
+# Contributor: jdkaplan <jdkaplan@metagram.net>
pkgname=tako-git
_gitname=tako
-pkgver=0.2.5
-pkgrel=2
+pkgver=r3747.50bc4f7b
+pkgrel=1
pkgdesc="A command language and shell based on Python"
arch=('any')
-url="https://gitlab.com/adqm/$_gitname"
+url="https://takoshell.org/index.html"
license=('GPL3')
depends=('python')
makedepends=('python-setuptools' 'git')
conflicts=('tako')
install=tako.install
-source=("git+https://gitlab.com/adqm/$_gitname.git")
+source=("git://hz.mit.edu/$_gitname.git")
sha256sums=('SKIP')
+
pkgver() {
cd "$_gitname"
- git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ python setup.py build
}
package() {
- cd "$srcdir/$_gitname"
- python setup.py install --root=$pkgdir
+ cd "$_gitname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}