summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKirill Pshenichnyi2023-02-21 11:52:54 +0300
committerKirill Pshenichnyi2023-02-21 12:12:39 +0300
commita8a60d91a53246d219c764c6ef27df7fac5fe4b3 (patch)
treed97634d2b4400876c9cf331acba4b3322625e0ed /PKGBUILD
parent87d1d95ae078e873763596e92e923d5b660451aa (diff)
downloadaur-tango-idl.tar.gz
change version: 5.1.0 => 5.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8b36f38f642..a08eccfa2515 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
# Maintainer: Kirill Pshenichnyi <pshcyrill@mail.ru>
+# Maintainer: Antonio Bartalesi <antonio.bartalesi@gmail.com>
# Contributor: The Tango Controls community
# (https://tango-controls.org) <info@tango-controls.org>
pkgname=tango-idl
-pkgver=5.1.0
+pkgver=5.1.2
pkgrel=1
groups=('tango-controls')
pkgdesc="This is the Tango CORBA IDL file."
arch=('x86_64' 'armv7h')
url="https://www.tango-controls.org/"
license=('GPL3')
-depends=('cmake>=2.8.9')
+depends=('cmake>=3.7')
conflicts=('tango-idl-git')
-source=("https://gitlab.com/tango-controls/tango-idl/-/archive/${pkgver}/tango-idl-${pkgver}.tar.gz")
-sha256sums=('864dc73510fea5d71c8d7120ecb0d0df13510b37319120367305b94490b5751e')
+source=("https://gitlab.com/tango-controls/tango-idl/-/archive/${pkgver}/tango-idl-${pkgver}.tar.gz"
+ "version-fix.patch")
+sha256sums=('b0a955d14c6c88fe331e2323205522a3710a4aa1909c1e7f3ee3acc371a5a77d'
+ 'fd4734107be21dcfc3388efef6ac1ebc3645956756c10ced0b956edee9cddb2d')
_dir="${pkgname}-${pkgver}"
+
prepare() {
- mkdir -p ${_dir}/build
+ cd "${pkgname}-${pkgver}"
+ patch -N --input="${srcdir}/version-fix.patch"
}
build() {
- cd ${_dir}/build
- cmake ../
+ cmake -B build -S "${pkgname}-${pkgver}" -DCMAKE_INSTALL_PREFIX=/usr
}
package() {
- cd ${_dir}/build
- make DESTDIR=${pkgdir} install
+ DESTDIR="$pkgdir" cmake --install build
}