summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikalai Ramanovich2016-11-13 16:34:51 +0300
committerMikalai Ramanovich2016-11-13 16:34:51 +0300
commit31bcf46be8c345efc4fbddb1cbaf931d943f1de4 (patch)
tree55e84a6b57486cced10092a5c5ac98c79811dc55 /PKGBUILD
downloadaur-tcplay-veracrypt.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90c78aa20af2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=tcplay-veracrypt
+pkgver=2.0
+pkgrel=1
+pkgdesc="Free and simple TrueCrypt implementation based on dm-crypt."
+arch=('i686' 'x86_64')
+url="https://github.com/veracrypt/tc-play"
+license=('BSD-2-Clause')
+depends=('device-mapper')
+makedepends=('cmake')
+provides=('tcplay')
+conflicts=('tcplay')
+replaces=('tcplay')
+source=("git+https://github.com/veracrypt/tc-play.git")
+
+sha256sums=('SKIP')
+
+prepare() {
+ cd "tc-play"
+ patch -Np1 -i ../../1.patch
+ patch -Np1 -i ../../2.patch
+}
+
+build() {
+ cd "tc-play"
+ mkdir -p objdir
+ cd objdir
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+}
+
+package() {
+ cd "tc-play/objdir"
+ make DESTDIR="$pkgdir" install
+ install -D -m644 ../LICENSE "$pkgdir"/usr/share/licenses/tcplay/LICENSE
+} \ No newline at end of file