summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDhruva Sambrani2024-04-15 15:32:10 +0200
committerDhruva Sambrani2024-04-15 15:32:10 +0200
commit4f62053817cc1c3acaf11d30b5ce8d00f06a669d (patch)
treeee8c750669e74530dff73736b6ddc20074f33cab /PKGBUILD
downloadaur-teams-for-linux-wayland-hook.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56b8263d6147
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Emanuel Serpa <emanuelvserpa@gmail.com>
+
+pkgname=teams-for-linux-wayland-hook
+pkgver=1
+pkgrel=1
+pkgdesc="Pacman hook to change teams-for-linux to start with electron flags to start with wayland after install or upgrade."
+arch=("any")
+install=teams-for-linux-wayland-hook.install
+license=("MIT")
+depends=('teams-for-linux')
+source=(teams-for-linux-wayland.hook teams-for-linux-wayland)
+sha1sums=('929fea9c7e64cf4d1de78277df852fdeb99597fd'
+ 'e59f8f67f089ec0dae9d8e9343a46a993bc6da41')
+
+package() {
+ install -m755 -d "${pkgdir}/usr/share/libalpm/hooks"
+ install -m644 "${srcdir}/teams-for-linux-wayland.hook" "${pkgdir}/usr/share/libalpm/hooks/teams-for-linux-wayland.hook"
+ install -m755 -d "${pkgdir}/usr/share/libalpm/scripts"
+ install -m755 "${srcdir}/teams-for-linux-wayland" "${pkgdir}/usr/share/libalpm/scripts/teams-for-linux-wayland"
+}