summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIvan Semkin2018-02-18 01:41:15 +0300
committerIvan Semkin2018-02-18 01:41:15 +0300
commitbf258268bb38a79fe5330298afea1b22d6ebafa9 (patch)
tree22dc190f932bca5e7fc0f0b4850b845c2442875c /PKGBUILD
downloadaur-template-glib-git.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d21f708eb11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Ivan Semkin (ivan at semkin dot ru)
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+_pkgname=template-glib
+pkgname=template-glib-git
+pkgver=3.27.90
+pkgrel=1
+pkgdesc="A templating library for GLib"
+url="https://git.gnome.org/browse/template-glib"
+arch=(x86_64)
+license=(LGPL)
+conflicts=(template-glib)
+provides=(template-glib)
+depends=(glib2 gobject-introspection-runtime)
+makedepends=(git meson vala gobject-introspection gtk-doc)
+source=("git+https://git.gnome.org/browse/template-glib")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson ../$_pkgname -Denable_gtk_doc=true
+ ninja
+}
+
+check() {
+ cd build
+ meson test
+}
+
+package() {
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}