summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNiklas Hedlund2015-10-01 17:58:57 +0200
committerNiklas Hedlund2015-10-01 17:58:57 +0200
commit19d994e5fce5bf006d0162769a7526a28c8a3463 (patch)
tree4923996494f0a8656b70d7b871cf987e8828215e /PKGBUILD
downloadaur-texlive-screenplay.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d67507c74667
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Original autor: John Pate
+# Maintainer: Niklas Hedlund nojan1989@gmail.com
+
+pkgname=texlive-screenplay
+pkgver=1.6
+pkgrel=1
+license=('GPL')
+depends=('texlive-core')
+pkgdesc="A LaTeX package for screenplay writing"
+url="http://www.ctan.org/tex-archive/macros/latex/contrib/screenplay"
+arch=('any')
+install=texlive-screenplay.install
+source=(http://mirrors.ctan.org/macros/latex/contrib/screenplay.zip)
+md5sums=('57ae9a3840985984b84cfe68a607f529')
+
+build()
+{
+ cd $srcdir/screenplay
+ latex screenplay.ins
+}
+
+package()
+{
+ cd $srcdir/screenplay
+
+ mkdir -p $pkgdir/usr/share/texmf/tex/latex/screenplay
+ cp {screenplay.cls,example.tex,hardmarg.sty} $pkgdir/usr/share/texmf/tex/latex/screenplay
+
+ mkdir -p $pkgdir/usr/share/doc/texlive-screenplay
+ cp screenplay.pdf $pkgdir/usr/share/doc/texlive-screenplay/documentation.pdf
+}