summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosip Ponjavic2022-03-15 20:33:56 +0100
committerJosip Ponjavic2022-03-15 20:33:56 +0100
commit034ba219346ebfb4422c755fa3eee181cd3f82f1 (patch)
treeaaf8430951194bfa1e180605cf5724cdd6240891 /PKGBUILD
parent07e2a85d0561eb15899415cd67873cab274b7821 (diff)
downloadaur-textsnatcher-git.tar.gz
upgpkg: 2.0.0.r0.g7192ac1-1 move scrot and xdg-desktop-portal to optdeps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9144b4603d38..8d6136ba259e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
# Contributor:
pkgname=textsnatcher-git
-pkgver=1.0.1.r34.g5faa700
+pkgver=2.0.0.r0.g7192ac1
pkgrel=1
pkgdesc='Copy Text from Images with ease, Perform OCR operations in seconds'
arch=('x86_64')
url="https://github.com/RajSolai/TextSnatcher"
license=('GPL3')
-depends=('granite' 'libhandy' 'libportal' 'scrot' 'tesseract' 'xdg-desktop-portal')
+depends=('granite' 'libhandy' 'libportal' 'tesseract')
makedepends=('git' 'meson' 'vala')
+optdepends=('scrot: screenshot engine for X11 systems'
+ 'xdg-desktop-portal: for wayland support, you will need the implementation for your wayland desktop environment')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
source=("${pkgname%-*}::git+${url}.git")
@@ -21,7 +23,7 @@ pkgver() {
}
build() {
- arch-meson ${pkgname%-*} build
+ arch-meson "${pkgname%-*}" build
ninja -C build
}