summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Tran2019-09-04 22:59:27 +1000
committerVictor Tran2019-09-04 22:59:27 +1000
commitd8f5ad49a225034bd86e7309ad82340b1908f417 (patch)
tree9eabe8f8c130fed248d1456b69cbdc1a5a291125 /PKGBUILD
parentee21ec4ee0b2d4bcac0f813a4bbef372194c1890 (diff)
downloadaur-theweb.tar.gz
Update to 16.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 9 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6abe936ba7e..d565c7d711ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,23 @@
# Maintainer: Victor Tran <vicr12345 at gmail dot com>
pkgname=theweb
-pkgver=15.0
+pkgver=16.0
pkgrel=0
-pkgdesc="Web Browser based on CEF and Qt"
+pkgdesc="Web Browser based on QtWebEngine"
arch=("x86_64")
url="https://github.com/vicr123/theweb"
license=('GPL3')
-depends=('kwidgetsaddons' 'xdg-utils' 'qt5-base' 'poppler-qt5')
-makedepends=('git' 'clang')
-source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theweb#branch=master'
- "http://opensource.spotify.com/cefbuilds/cef_binary_3.2840.1494.g7fe3d03_linux64_minimal.tar.bz2")
-md5sums=('SKIP'
- 'SKIP')
+depends=('xdg-utils' 'qt5-base' 'the-libs' 'qt5-webengine')
+makedepends=('git' 'nodejs' 'npm')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/theweb#branch=master')
+md5sums=('SKIP')
build() {
- cp "cef_binary_3.2840.1494.g7fe3d03_linux64_minimal/Release/libcef.so" "$pkgname-$pkgver"
cd "$pkgname-$pkgver"
- qmake
- make
+ node buildtool.js
}
package() {
- mkdir -p "$pkgdir/opt/theWeb"
- cp "$pkgname-$pkgver/theweb" "$pkgdir/opt/theWeb"
- cp -r "cef_binary_3.2840.1494.g7fe3d03_linux64_minimal/Release/"* "$pkgdir/opt/theWeb"
- cp -r "cef_binary_3.2840.1494.g7fe3d03_linux64_minimal/Resources/"* "$pkgdir/opt/theWeb"
- cp "$pkgname-$pkgver/libcef_dll_wrapper.a" "$pkgdir/opt/theWeb"
- chmod 4755 "$pkgdir/opt/theWeb/chrome-sandbox"
- mkdir -p "$pkgdir/usr/share/applications"
- cp "$pkgname-$pkgver/theweb.desktop" "$pkgdir/usr/share/applications"
- mkdir -p "$pkgdir/usr/bin/"
- cp "$pkgname-$pkgver/theweb-execscript" "$pkgdir/usr/bin/theweb"
- mkdir -p "$pkgdir/usr/share/icons"
- cp "$pkgname-$pkgver/icon.svg" "$pkgdir/usr/share/icons/theweb.svg"
+ cd "$pkgname-$pkgver"/build
+ make install INSTALL_ROOT=$pkgdir
}