summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDominik Schwaiger2022-05-21 16:33:36 +0200
committerDominik Schwaiger2022-05-21 16:33:36 +0200
commit8ae13483402c17440fdb94c150a1eb8e555f335f (patch)
tree073b093111f415fce10310c08afdf9ad48e7a7c5 /PKGBUILD
parenta092e44d47e9508ecaea33520943b152eb221207 (diff)
downloadaur-thunar-nextcloud-plugin.tar.gz
compile step moved into build function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b086cf9562ca..0bf11476e048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Dominik Schwaiger <mail@dominik-schwaiger.ch>
pkgname=thunar-nextcloud-plugin
pkgver=1.0
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc=" A plugin for sharing files via the Nextcloud client from within the Thunar file manager"
arch=("x86_64")
url="https://github.com/frederikmoellers/thunar-nextcloud-plugin"
license=('GPL-3')
groups=()
-depends=("thunar" "nextcloud-client" "gcc" "unzip" "gtk3")
-makedepends=()
+depends=("thunar" "nextcloud-client" "gtk3")
+makedepends=("gcc" "unzip" "bash")
checkdepends=()
optdepends=()
provides=()
@@ -24,9 +24,13 @@ noextract=()
sha256sums=("d43e249fb9771a857dcca706a912cc631da7bbe259e5cdaac2a7eaa725ffda82")
validpgpkeys=()
-package() {
+build() {
unzip -f 3015ee5bce2db072a2eeaa158150af2d7c0bfba6.zip
cd thunar-nextcloud-plugin-3015ee5bce2db072a2eeaa158150af2d7c0bfba6
bash compile.sh
+}
+
+package() {
+ cd thunar-nextcloud-plugin-3015ee5bce2db072a2eeaa158150af2d7c0bfba6
install -D thunar-nextcloud-plugin.so "$pkgdir"/usr/lib/thunarx-3/thunar-nextcloud-plugin.so
}