summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2020-05-12 15:40:21 -0400
committerTed Alff2020-05-12 15:40:21 -0400
commite4dec960d8ddcaa72be12a906deafcfbc5343b3a (patch)
tree129eba19ab52729cc88ed5f530a1c0ef3d9b684e /PKGBUILD
parent7fa4ecffd3518e7c534f1de73177985c9038de12 (diff)
downloadaur-thunar-vcs-plugin-git.tar.gz
Update source to gitlab.xfce.org
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdbc0f0c2824..ffe2ce30d736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
_pkgname=thunar-vcs-plugin
pkgname=${_pkgname}-git
-pkgver=0.1.90+2+g31b819c
+pkgver=0.2.0+87+gcf09392
pkgrel=1
pkgdesc="SVN and GIT integration for Thunar."
-arch=('i686' 'x86_64')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
license=('GPL')
url="https://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
depends=('thunar>=1.7.0' 'git' 'subversion' 'apr')
makedepends=('intltool' 'xfce4-dev-tools')
provides=("${_pkgname}=${pkgver%%+*}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git://git.xfce.org/thunar-plugins/thunar-vcs-plugin")
+source=("${_pkgname}::git+https://gitlab.xfce.org/thunar-plugins/${_pkgname}")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed -r "s:^${_pkgname}-::;s/-/+/g"
+ git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^v//;s/^xfce-//;s/-/+/g"
}
build() {
@@ -28,5 +28,5 @@ build() {
package() {
cd "${_pkgname}"
- make DESTDIR=$pkgdir install
+ make DESTDIR="${pkgdir}" install
}