summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Lamarra2017-11-12 06:59:06 -0600
committerAndrew Lamarra2017-11-12 06:59:06 -0600
commite1b7fdf43319b3e57aa1516b759e73b25ddc6038 (patch)
tree62fad7006040cdeec23990c9fb7e5e39aa970657 /PKGBUILD
parent497c44f1b2a12943fadcf78e7f939a493132c5f0 (diff)
downloadaur-timertab.tar.gz
Only copy the compltion script if the directory exists
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d981d2b9d9be..e2cdfc65d098 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,5 +13,7 @@ sha256sums=('bbd12cab218016f825a3eab50bca58facb5bff4f780c89e6545083eb6dd5037f')
package () {
install -Dm755 "$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 "$pkgname-$pkgver/completion/${pkgname}_completion" "$pkgdir/etc/bash_completion.d/${pkgname}_completion"
- install -Dm644 "$pkgname-$pkgver/completion/_${pkgname}" "$pkgdir/usr/share/zsh/functions/Completion/Zsh/_${pkgname}"
+ if [ -d /usr/share/zsh/functions/Completion/Zsh ]; then
+ install -Dm644 "$pkgname-$pkgver/completion/_${pkgname}" "$pkgdir/usr/share/zsh/functions/Completion/Zsh/_${pkgname}"
+ fi
}