summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-07-26 23:19:26 +0000
committerGeorge Rawlinson2022-07-26 23:19:26 +0000
commit17cd4c2f57f3612b271d0389aa25efab50f04b41 (patch)
tree1c93581b30584751752ec0427d32de6dd4c7cef7 /PKGBUILD
parentf7828aa6209112c57a39a8fb3df267fdd7a8e6db (diff)
downloadaur-timescaledb-parallel-copy.tar.gz
upgpkg: timescaledb-parallel-copy 0.4.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55eb121f0361..14cbbf031cc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,27 @@
# Maintainer: George Rawlinson <george@rawlinson.net.nz>
pkgname=timescaledb-parallel-copy
-pkgver=0.3.0
-pkgrel=3
-pkgdesc="A tool for parallel copying of CSV data into a TimescaleDB hypertable"
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='A tool for parallel copying of CSV data into a TimescaleDB hypertable'
arch=('x86_64')
-url="https://github.com/timescale/timescaledb-parallel-copy"
+url='https://github.com/timescale/timescaledb-parallel-copy'
license=('Apache')
depends=('glibc')
-makedepends=('go')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('2564fb960ee0847696482e8fb79007ad4d4c92ca0dce6df396d732c203ba35fa8af69de183c6e25a1cac15a82cd56e7dd826584252fea01c65f2226b213d9567')
-b2sums=('1865dec51c3446fe32d62290cb268b6cb61fa405acb7bbc314984b25c381bacabe04f2ce870fa9a47405b2161aa64d2f4afb18c07ede27e34de8976c99924b13')
+makedepends=('git' 'go')
+options=('!lto')
+_commit='c0b5b0d8cefaacc9929f96e28e06b4c782ea3e90'
+source=("$pkgname::git+$url#commit=$_commit")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed 's/^v//'
+}
prepare() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
# create directory for build output
mkdir -p build
@@ -24,7 +31,8 @@ prepare() {
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
+
go build -v \
-buildmode=pie \
-trimpath \
@@ -36,5 +44,8 @@ build() {
}
package() {
- install -Dm755 -t "$pkgdir/usr/bin" "$pkgname-$pkgver/build/$pkgname"
+ cd "$pkgname"
+
+ # binary
+ install -vDm755 -t "$pkgdir/usr/bin" "build/$pkgname"
}