summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Taboada2021-01-14 08:06:59 -0800
committerMichael Taboada2021-01-14 08:06:59 -0800
commit014208e26c5a78639c534b9b07a2301b99355d55 (patch)
tree865d93ce118f83116efbac607045b07789d32f76 /PKGBUILD
parent8c56c08216df56a5dc4de7c4557462e4882fa72a (diff)
downloadaur-tintin-beta.tar.gz
Fix date to use the actual last modified date
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5d1e4763fc2..6ac41ee30cd0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
+# Maintainer: Michael Taboada <michael@2mb.solutions>
_pkgname="tintin"
pkgname="tintin-beta"
-pkgver=2019.04.11
+pkgver=2021.01.10
pkgrel=1
+epoch=1
pkgdesc="A console-based MUD client beta version"
arch=('aarch64' 'armv7h' 'i686' 'x86_64')
url="http://tintin.sourceforge.net/"
@@ -13,12 +15,17 @@ options=('strip')
source=('http://tintin.sourceforge.net/download/tintin-beta.tar.gz')
conflicts=("tt++" "tintin")
provides=("tt++" "tintin")
-replaces=("tt++" "tintin")
md5sums=('SKIP')
pkgver() {
- # Because there is no version number, the date will be used in yymmdd format.
- date '+%Y.%m.%d'
+ # Because there is no version number, the date of last modification will be used in yymmdd format.
+ date="$(date '+%Y.%m.%d' -d "$(curl -L -s -i -I 'http://tintin.sourceforge.net/download/tintin-beta.tar.gz' | grep 'last-modified' | cut -d: -f2 | cut -d\ -f2-)")"
+ if [[ "$date" =~ ^[0-9]{4}\.[0-9]{2}\.[0-9]{2}$ ]] ; then
+ echo "$date"
+ else
+ echo "Error getting last modified date" >&2
+ exit 1
+ fi
}
build() {