summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKristopher James Kent2024-07-01 04:29:35 +0100
committerKristopher James Kent2024-07-01 04:29:35 +0100
commit6c30a1be1adba1bf50fbfbe8f1c1085bd0c615c1 (patch)
treeca8d61644b96986d5257ca86abcf8331f4df6de2 /PKGBUILD
parente9260b0a1121a0758fb88e5cdb368078fcf073ae (diff)
downloadaur-tio-git.tar.gz
PKGBUILD updates to track upstream build changes
`depends` and `makedepends` now track what is present on the upstream tio repo. Other minor changes to PKGBUILD include updating of meson command, package URL, and licence now matches SPDX indentifier.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fe523ba5120..84a1f9a0721f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
-# Maintainer: Martin Hundebøll <martin@hundeboll.net>
-_pkgname=tio
-pkgname=$_pkgname-git
-pkgver=1.36.r2.g8975c44
+# Maintainer: Nick Østergaard <oe.nick@gmail.com>
+# Co-maintainer: Kristopher James Kent <aur@kjkent.dev>
+# Contributor: Martin Hundebøll <martin@hundeboll.net>
+
+pkgname='tio-git'
+_pkgname="${pkgname%%-git}"
+pkgver='3.5.r1.g02cac07'
pkgrel=1
-pkgdesc="The simple TTY terminal I/O application"
-url="http://tio.github.io"
+pkgdesc='A serial device I/O tool'
+url='https://github.com/tio/tio'
arch=('x86_64' 'i686')
-license=('GPLv2')
-conflicts=('tio')
-provides=('tio')
-depends=('glibc' 'libinih')
+license=('GPL-2.0-or-later')
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+depends=('glib2' 'lua')
makedepends=('git' 'meson')
-source=("git+https://github.com/tio/tio.git")
+source=("git+$url.git")
sha256sums=('SKIP')
pkgver() {
@@ -21,7 +24,7 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
- meson --prefix=/usr --buildtype=plain . build
+ meson setup --prefix=/usr --buildtype=plain . build
meson compile -C build
}