summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPieter Goetschalckx2017-06-21 15:20:29 +0200
committerPieter Goetschalckx2017-06-21 15:20:29 +0200
commite003ee8562cc2e944de8476bb9124e145c852ccf (patch)
tree8fb72d7bfa3f9dd9954f75e39ae5af05b65e9c7f /PKGBUILD
parentac5950c7d36a6890bf4a4fbfc741eadd4580a7d8 (diff)
downloadaur-tis-interpreter-git.tar.gz
Fix fatal warnings
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fb202911ccb..1c927066ae8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
_pkgname=tis-interpreter
pkgname=$_pkgname-git
-pkgver=r47.e8de317
+pkgver=r95.33132ce
pkgrel=1
pkgdesc="An interpreter for finding subtle bugs in programs written in standard C"
arch=('i686' 'x86_64')
url="https://github.com/TrustInSoft/tis-interpreter"
license=('LGPL2.1')
-depends=('ocaml' 'ocaml-findlib' 'zarith' 'ocaml-easy-format' 'ocaml-biniou' 'ocaml-yojson')
-makedepends=('git')
+makedepends=('git' 'ocaml' 'ocaml-findlib' 'zarith' 'ocaml-easy-format' 'ocaml-biniou' 'ocaml-yojson')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/TrustInSoft/$_pkgname")
-sha256sums=('SKIP')
+source=("frama-c-ocaml-4-04.patch" "git+https://github.com/TrustInSoft/$_pkgname")
+sha256sums=('b6f7c77da046b558328c901a9e176c6d4ee361aa11eb8e6cc87971290c6b2525'
+ 'SKIP')
pkgver() {
cd "$_pkgname"
@@ -24,13 +24,14 @@ prepare() {
cd "$_pkgname"
sed -i 's#^ROOT_PATH=.*$#ROOT_PATH=/usr/share/tis-interpreter#' "tis-interpreter/tis-interpreter.sh"
sed -i 's#^TIS_PATH=.*$#TIS_PATH=/usr#' "tis-interpreter/tis-interpreter.sh"
+ patch -p1 -i "$srcdir/frama-c-ocaml-4-04.patch"
}
build() {
cd "$_pkgname"
./configure --prefix=/usr --disable-from_analysis --disable-gui --disable-impact --disable-inout --disable-metrics --disable-occurrence --disable-pdg --disable-postdominators --enable-rtegen --disable-scope --disable-slicing --disable-sparecode --enable-users --disable-aorai --disable-obfuscator --disable-report --disable-security_slicing --disable-wp --disable-wp-coq --disable-wp-why3 --disable-print_api --with-all-static
make depend
- make
+ make WARNINGS="-w @a-3-4-6-9-41-44-45-48-50-60"
}
package() {