summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRoboron30422023-05-07 18:04:38 +0200
committerRoboron30422023-05-07 18:04:38 +0200
commit2b5948643a97a5933093b8839aad22b84f9b0a9e (patch)
tree9a0f60725db2878e557712b18129d2502f56b997 /PKGBUILD
parentea9a428821dc376aac37ef3f9a373c910a397a7a (diff)
downloadaur-tootle-git.tar.gz
Switched to gitlab repository
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a478dd7dee70..909e0a174781 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Jean Lucas <jean@4ray.co>
pkgname=tootle-git
-pkgver=2.0.alpha1.r5.g1010a78
+pkgver=r438.b4046da
pkgrel=1
pkgdesc='GTK4 client for Mastodon (git)'
arch=('i686' 'x86_64' 'aarch64')
-url=https://github.com/bleakgrey/tootle
+url=https://gitlab.gnome.org/World/tootle.git
license=(GPL3)
-depends=(granite libhandy gtk4)
-makedepends=(git meson ninja vala gobject-introspection libadwaita)
+depends=(granite libhandy gtk4 libadwaita libsoup)
+makedepends=(git meson ninja vala gobject-introspection)
provides=(tootle)
conflicts=(tootle)
source=(git+$url)
@@ -18,7 +18,8 @@ sha512sums=('SKIP')
pkgver() {
cd tootle
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
#| cut -c2-48
}