summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDani Rodríguez2024-02-19 08:50:34 +0100
committerDani Rodríguez2024-02-19 08:50:34 +0100
commit84a82fd076e1207b4914ddf2d6c27f8617e98f51 (patch)
treeddeb338e74d32d26bc38f53ec6c2c6724e67606f /PKGBUILD
parentfad391215c4e17dfff07ea438b337e08180c4351 (diff)
downloadaur-tootstream.tar.gz
Bump to tootstream 0.4.0
Bumps PKGBUILD to 0.4.0, the latest released and numbered version of this package. A patch is provided to fix the runtime errors introduced by a breaking change in an upstream dependency. Patch is taken from commit 32041df30c838a75bc2863a36eb1442bfaba3e70 from the tootstream repository. (See https://github.com/magicalraccoon/tootstream/issues/231). Aside from that, no other commits are cherry-picked (that's the purpose of tootstream-git, which is the Git tip). The package currently compiles, sometimes shows a warning about using a deprecated setup.py build command, but these are part of the build instructions of the upstream repository so I am not touching that. Also updates SRCINFO and moves former maintainers as contributors.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7aaa58fd85b7..0b3c8b389283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
-# Maintainer: Marc Grondin <myself AT marcg DOT pizza>
-# Maintainer: Daniel Moch <daniel AT danielmoch DOT com>
+# Maintainer: Dani Rodríguez <dani@danirod.es>
+# Contributor: Marc Grondin <myself AT marcg DOT pizza>
+# Contributor: Daniel Moch <daniel AT danielmoch DOT com>
# Contributor: Drew DeVault <sir@cmpwn.com>
pkgname=tootstream
-pkgver=0.3.8.1
+pkgver=0.4.0
pkgrel=1
pkgdesc="Text interface for the Mastodon social network"
arch=(any)
@@ -14,13 +15,14 @@ depends=(python-mastodon
python-colored
python-emoji)
makedepends=(python-distribute)
-source=("requirements.txt.patch"
- "${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('9ca9c83eada78ee42f011c6e3bd8e5b01caf770b1c3b152238a8e13ff26138d6'
- '69886966c98d6fdbf051958832f80c2b5364393796f42f011083ee25fc5ab7f8')
+source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "0001-Fix-for-later-versions-of-colored.patch")
+sha256sums=('ae30d2cec798d9b72eed378c5181c00cf3a5177ab09bb71fd6e4e20f9f860c93'
+ 'e2fe90e24b1ddcb6f20d7d6bbda2b89871188ae65317d6d0952f1c8fe3bc44ee')
prepare() {
- patch ${pkgname}-${pkgver}/requirements.txt requirements.txt.patch
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -s < "${srcdir}/0001-Fix-for-later-versions-of-colored.patch"
}
build() {