summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-06-01 21:28:05 +0000
committerBioArchLinuxBot2023-06-01 21:28:05 +0000
commita727a0369c93b7da216c02d5ece53c8e213f114f (patch)
treece26253450a52adfb3b4e16d52b972b8c0acdc41 /PKGBUILD
parent4bb5f7f538b0640f41d78651cbef939ac46b91c7 (diff)
downloadaur-tophat.tar.gz
[lilac] updated to 2.1.2-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 30 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e38a5ba93bc9..018b909a30ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
pkgname=tophat
-pkgver=2.1.1
-pkgrel=2
+pkgver=2.1.2
+pkgrel=3
pkgdesc="fast splice junction mapper for RNA-Seq reads"
arch=('x86_64' 'i686')
url="http://ccb.jhu.edu/software/tophat/index.shtml"
license=('custom')
-depends=('boost-libs' 'bowtie2' 'python2')
-makedepends=('boost')
-source=("http://ccb.jhu.edu/software/tophat/downloads/tophat-$pkgver.tar.gz"
- 'make_pair.patch')
-md5sums=('4b2391de46457ba6b2b7268a9da593e4'
- '53378885f3620a1d02fb345077609d05')
+depends=('boost-libs' 'bowtie2' 'python')
+makedepends=('boost' 'clang')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/DaehwanKimLab/tophat/archive/refs/tags/v${pkgver}.tar.gz"
+ 'make_pair.patch'
+ 'configure.patch'
+ )
+md5sums=('db844fd7f53c519e716cd6222e6195b2'
+ '4f53cd3e611c2a0744babede14c3ae66'
+ '175420b0b08f2979d9585ec55cbeb0ee')
prepare() {
cd $srcdir/$pkgname-$pkgver
@@ -20,22 +23,28 @@ prepare() {
sed -e 's|make $(SAMPROG)|make -e $(SAMPROG)|' \
-i src/Makefile.am
- sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
- -i src/bed_to_juncs \
- src/contig_to_chr_coords \
- src/sra_to_solid \
- src/tophat-fusion-post \
- src/tophat.py
+ # sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
+ # -i src/bed_to_juncs \
+ # src/contig_to_chr_coords \
+ # src/sra_to_solid \
+ # src/tophat-fusion-post \
+ # src/tophat.py
+
+ # to python3
+ 2to3 -w -n .
patch -Np1 -i $srcdir/make_pair.patch
+ patch -Np0 -i $srcdir/configure.patch
+ autoreconf -i
+ autoupdate
+ autoconf
}
build() {
cd $srcdir/$pkgname-$pkgver
-
- export PYTHON=python2
-
- ./configure --prefix=/usr
+ export CC=clang
+ export CXX=clang++
+ ./configure --prefix=/usr --with-python-sys-prefix
# do not link against system-installed libbam.a
sed -e 's|-L/usr/lib||' \
@@ -50,9 +59,10 @@ package() {
make DESTDIR=$pkgdir install
# fix python install
- install -d $pkgdir/usr/lib/python2.7/site-packages
+ _pyver=$(python -V | cut -d ' ' -f2)
+ install -d $pkgdir/usr/lib/python${_pyver:0:4}/site-packages
mv \
- -t $pkgdir/usr/lib/python2.7/site-packages \
+ -t $pkgdir/usr/lib/python${_pyver:0:4}/site-packages \
$pkgdir/usr/bin/{intervaltree,sortedcontainers}
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE