summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarco Rubin2024-03-10 09:07:11 +0100
committerMarco Rubin2024-03-10 09:07:11 +0100
commit425f7e1b03f68b8e451ea5523d23cfada9b079ca (patch)
treef2d5a1743197998bbee330e2a61fbcc796415fcd /PKGBUILD
parent72c761d1404ffed77624be79941f0869e8475d11 (diff)
downloadaur-torrentinfo.tar.gz
PEP 517 building
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f65c374a2d51..ece95317772d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=torrentinfo
pkgver=1.8.7
-pkgrel=2
+pkgrel=3
pkgdesc="Bittorrent .torrent file parser and summariser"
arch=('any')
url="https://github.com/Fuuzetsu/torrentinfo"
license=(GPL2)
depends=(python)
-makedepends=(git python-setuptools)
+makedepends=(git python-build python-installer python-setuptools python-wheel)
source=("git+$url#commit=3c9b3ba80c867ba28e8ce0982fec8ea5369df8ef")
b2sums=('SKIP')
@@ -21,10 +21,10 @@ prepare() {
build() {
cd $pkgname
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}