summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-07-24 19:57:46 +0000
committerDaniel Bermond2020-07-24 19:57:46 +0000
commit4df639097ea469f8bbb10f9e83404a5dc7ad0923 (patch)
tree59a9604e4e80a2a2b40e76a56a6c4af34d930c77 /PKGBUILD
parent43aec0b08bdbaf9ba1a2f7bc7842a377f0151314 (diff)
downloadaur-torrentzip.net-git.tar.gz
Update patches. Fix provides/conflicts. General improvements.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD77
1 files changed, 26 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d7e1a75c45c..8649a234d646 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,72 +1,50 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=torrentzip.net-git
-_srcname=RVWorld
-pkgver=r17.7513f4e
+pkgver=r117.g911adca
pkgrel=1
pkgdesc='Torrentzip utility with mutli core processing capability (git version)'
arch=('any')
url='http://www.romvault.com/trrntzip/'
license=('MIT')
depends=('mono' 'sh' 'hicolor-icon-theme')
-makedepends=('git' 'imagemagick')
-provides=('torrentip.net')
-conflicts=('torrentip.net')
+makedepends=('git' 'icoutils')
+provides=('torrentzip.net')
+conflicts=('torrentzip.net')
source=('git+https://github.com/RomVault/RVWorld.git'
'TrrntZip.NET'
'TrrntZipUI'
'torrentzip.net.desktop'
- 'torrentzip.net-git-no-ilmerge.patch'
- 'torrentzip.net-git-fix-case.patch'
- 'torrentzip.net-git-linux-fix.patch')
+ '010-torrentzip.net-no-ilrepack.patch'
+ '020-torrentzip.net-fix-case.patch')
sha256sums=('SKIP'
'fcec85063da4f78dc853f443493709458ae627aaf8968476c7ea02056b0982b0'
'af32f3a2609a9eae37a2c836b0a4961230cfdffec6080d23fc94c5a0c4a181f0'
- 'ab1f7bd79b7f255ee93b7986e3b8674eb32150c1043e349f351db2c29788aebe'
- '6173068d16ca19f6b8e29cf176d0633a5b4a81b2986bd36a85e0fe5fa095a9f6'
- '5f54911530550c5e4379422cbacea6258c7a0e07429b3530a12a6daad157585e'
- '170fc46eb2af90ad47a76bbc3827219f024fe9b5df95b317202396ec299ae06d')
+ '3c5d111bca9db45bb093c7eef68194251a4c8e5659f6f632cb6f1d9789cef983'
+ 'fd8835e88f4db12f2e57294903c1a90ccb6d7eddf20f23433c054a9ab2e74fd4'
+ '5612ae7151aca3e376bd886cd2fccada031366830ab380092cc4a9d89c5f2946')
prepare() {
- cd "$_srcname"
-
- # apply patches:
- ## - do not statically link with ilmerge
- ## - fix case to allow building on linux
- ## - other linux fixes: more case fixes and .zip filename fix
- for _patch in "${source[@]}"
- do
- [ "${_patch##*.}" != 'patch' ] && continue
- printf '%s\n' " -> Applying patch '${_patch}'..."
- patch -Np1 -i "${srcdir}/${_patch}"
- done
-
- # convert .ico to suitable formats
- cd TrrntZipUI
- magick convert memory-rom.ico torrentzip.net.png
- magick convert memory-rom.ico torrentzip.net.svg
+ patch -d RVWorld -Np1 -i "${srcdir}/010-torrentzip.net-no-ilrepack.patch"
+ patch -d RVWorld -Np1 -i "${srcdir}/020-torrentzip.net-fix-case.patch"
+ icotool -x RVWorld/TrrntZipUI/memory-rom.ico -o RVWorld/TrrntZipUI
}
pkgver() {
- cd "$_srcname"
-
- # git, no tags available
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf 'r%s.g%s' "$(git -C RVWorld rev-list --count HEAD)" "$(git -C RVWorld rev-parse --short HEAD)"
}
build() {
printf '%s\n' ' -> Building TorrnetZip.NET CLI...'
- cd "${_srcname}/TrrntZipCMD"
+ cd RVWorld/TrrntZipCMD
xbuild /p:Configuration='Release' TrrntZipCMD.csproj
printf '%s\n' ' -> Building TorrnetZip.NET GUI...'
- cd "${srcdir}/${_srcname}/TrrntZipUI"
+ cd "${srcdir}/RVWorld/TrrntZipUI"
xbuild /p:Configuration='Release' TrrntZipUI.csproj
}
package() {
- local _pkgbasename="${pkgname%-git}"
-
# launchers
install -D -m755 TrrntZip.NET -t "${pkgdir}/usr/bin"
install -D -m755 TrrntZipUI -t "${pkgdir}/usr/bin"
@@ -74,25 +52,22 @@ package() {
ln -s TrrntZipUI "${pkgdir}/usr/bin/trrntzip.net-ui"
# binaries
- cd "$_srcname"
- install -D -m644 TrrntZipCMD/bin/Release/* -t "${pkgdir}/usr/lib/${_pkgbasename}"
- install -D -m644 TrrntZipUI/bin/Release/TrrntZipUI.* -t "${pkgdir}/usr/lib/${_pkgbasename}"
+ install -D -m644 RVWorld/Trrntzip/bin//Release/{Compress,RVIO,Trrntzip}.{dll,pdb} -t "${pkgdir}/usr/lib/${pkgname%-git}"
+ install -D -m644 RVWorld/TrrntZipCMD/obj/Release/TrrntZip.NET.{exe,pdb} -t "${pkgdir}/usr/lib/${pkgname%-git}"
+ install -D -m644 RVWorld/TrrntZipUI/obj/Release/TrrntZipUI.{exe,pdb} -t "${pkgdir}/usr/lib/${pkgname%-git}"
# desktop file
install -D -m644 "${srcdir}/torrentzip.net.desktop" -t "${pkgdir}/usr/share/applications"
# icons
- local _icon
- local -a _icons
- local _size
- mapfile -t -d '' _icons < <(find TrrntZipUI -type f -name 'torrentzip.net*.png' -print0)
- for _icon in "${_icons[@]}"
+ local _file
+ local _res
+ while read -r -d '' _file
do
- _size="$(magick identify -format '%[fx:w]' "$_icon")"
- install -D -m644 "$_icon" "${pkgdir}/usr/share/icons/hicolor/${_size}x${_size}/apps/${_pkgbasename}.png"
- done
- install -D -m644 TrrntZipUI/torrentzip.net.svg -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
+ _res="$(printf '%s' "$_file" | sed 's/\.png$//;s/^.*_//;s/x.*$//')"
+ install -D -m644 "$_file" "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/${pkgname%-git}.png"
+ done < <(find RVWorld/TrrntZipUI -maxdepth 1 -type f -name 'memory-rom_*_*x*x*.png' -print0)
# license
- install -D -m644 "${srcdir}/${_srcname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -D -m644 RVWorld/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname%-git}"
}