summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-01-21 17:10:38 -0700
committerMark Wagie2024-01-21 17:10:38 -0700
commite784355bded680f6ae4dc1c143106de371e80c1f (patch)
tree4c3220723653690a0d8c8ec8289a0f2f84c582dd /PKGBUILD
parentda9c2aecd9f7f128a3170d198d93764dc443d239 (diff)
downloadaur-touchpad-indicator-git.tar.gz
fixes & improvements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 562b4e2a9efc..7a93613c8679 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,24 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Ted Alff <twa022 at gmail dot com>
pkgname=touchpad-indicator-git
-pkgver=2.2.3.ubuntu20.04.0.r133.b789619
+pkgver=2.2.3.ubuntu20.04.0.r137.86064c7
pkgrel=1
pkgdesc="An indicator for the touchpad"
arch=('any')
url="https://github.com/atareao/Touchpad-Indicator"
-license=('GPL3')
-depends=('gdk-pixbuf2' 'libappindicator-gtk3' 'libnotify' 'lsb-release' 'librsvg'
- 'python-xlib' 'python-pyudev' 'python-dbus' 'python-evdev' 'xorg-xinput')
+license=('GPL-3.0-or-later')
+depends=(
+ 'gtk3'
+ 'libappindicator-gtk3'
+ 'libnotify'
+ 'lsb-release'
+ 'librsvg'
+ 'python-xlib'
+ 'python-pyudev'
+ 'python-dbus'
+ 'python-evdev'
+ 'xorg-xinput'
+)
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -16,13 +26,13 @@ source=("${pkgname%-git}::git+https://github.com/atareao/Touchpad-Indicator.git"
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
printf "%s.r%s.%s" "$(head -n 1 debian/changelog | cut -d'(' -f 2 | cut -d')' -f 1 | \
sed 's/-/./')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
# Install locales to correct directory
find . -type f -exec \
@@ -36,7 +46,7 @@ prepare() {
}
package() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgname%-git}"
while read _in _out ; do
mkdir -p "$pkgdir/$_out/"
install -m644 ${_in} "$pkgdir/$_out/"