summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael von Domaros2021-05-21 16:02:43 +0200
committerMichael von Domaros2021-05-21 16:02:43 +0200
commitcce909ce8b495a17cbacf9d781c73609f2cbf79b (patch)
tree2beb7691716542f9d1145651369948c3d12d89e1 /PKGBUILD
parentc0070b8ee8d490df11a0321aa23b3d154b33801a (diff)
downloadaur-travis.tar.gz
Update to 210521.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 55b598146e50..d998757cb5b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,31 @@
# Maintainer: Michael von Domaros <mvondomaros at gmail dot com>
pkgname=travis
-pkgver=200504
-pkgrel=2
+pkgver=210521
+pkgrel=1
pkgdesc="Trajectory Analyzer and Visualizer"
arch=('i686' 'x86_64')
url="http://www.travis-analyzer.de"
license=('GPL3')
depends=('gcc-libs')
options=('!strip')
-source=($url/files/$pkgname-src-$pkgver-hf2.tar.gz)
-md5sums=('c724e4170080db8f6e1cf5c0bc8d5013')
+source=($url/files/$pkgname-src-$pkgver.tar.gz)
+md5sums=('b94edc9f268cb824800c86594e39826c')
_cdsrcdir() {
- cd "$srcdir/$pkgname-src-$pkgver-hf2"
+ cd "$srcdir/$pkgname-src-$pkgver"
}
prepare() {
_cdsrcdir
+ # Delete Makefile CFLAGS. We will set them as environment variable below.
sed -i '/CFLAGS \+=/d' Makefile
}
build() {
_cdsrcdir
- export CFLAGS="$CFLAGS -g -ansi -O3 -march=native"
+ # Set CFLAGS.
+ export CFLAGS="$CFLAGS -g -ansi -std=c++14 -fsigned-char -pthread -O3 -march=native"
make
}