summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDominic2023-04-21 13:53:49 +0200
committerDominic2023-04-21 13:53:49 +0200
commit674301afd3925026d81e7b009e00e09c9bef7efb (patch)
tree6e1d94743ca4264b1fea303f3300cc1775cecc57 /PKGBUILD
parentf80439889023826d588a42283bbf479453d81d4c (diff)
downloadaur-trust-dns.tar.gz
trust-dns 0.22.0-5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d16127c77cd..242c40c4908e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,16 @@
_crate="trust-dns"
pkgname="trust-dns"
pkgver=0.22.0
-pkgrel=4
+pkgrel=5
pkgdesc='Trust-DNS is a safe and secure DNS server with DNSEC support. Eventually this...'
url='http://www.trust-dns.org/index.html'
license=('Apache' 'MIT')
depends=('gcc-libs')
makedepends=('cargo')
-conflicts=('bind')
+conflicts=('bind' 'trust-dns-systemd')
+provides=('trust-dns-systemd')
+replaces=('trust-dns-systemd')
source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/trust-dns/0.22.0/download"
"0001-fix-not-linking-openssl.patch"
@@ -34,7 +36,7 @@ build() {
cd "$srcdir/$_crate-$pkgver"
cargo build \
--offline \
- --features 'dns-over-tls,dns-over-https-rustls' \
+ --features 'dns-over-rustls,dns-over-https-rustls,dns-over-quic' \
--release
}