summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Jenkins2023-09-07 16:11:30 +0100
committerMatt Jenkins2023-09-07 16:11:30 +0100
commit4c06cff5c93b023939712a856daa8b5aee8dfcc3 (patch)
tree8b332fd8a74a3f35a30653d4cf02a3659c41a786 /PKGBUILD
downloadaur-tt2bin-git.tar.gz
Initial submission
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b3eec378292
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Majenko <matt@majenko.co.uk>
+pkgname=tt2bin-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Truth Table to Binary converter"
+arch=('any')
+url=https://github.com/MajenkoProjects/tt2bin
+license=('BSD')
+
+source=("git+https://github.com/MajenkoProjects/tt2bin.git")
+cksums=(SKIP)
+
+build() {
+ cd "tt2bin"
+ make
+}
+
+package() {
+ cd "tt2bin"
+ mkdir -p "$pkgdir/usr/bin/"
+ install -m 755 tt2bin "$pkgdir/usr/bin/"
+}