summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordplusplus2020-07-28 20:03:28 -0700
committerdplusplus2020-07-28 20:06:25 -0700
commit67729355d531f2945f90c7d4434808db3722a94b (patch)
treeb5d697edd99cf11b7a43829d6446141e0a8c026f /PKGBUILD
downloadaur-ttf-antonio.tar.gz
PKGBUILD and .SRCINFO files added for installing the Antonio font
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be8326ba873a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: dplusdplus <echo cmFuZG9tdGVzdG5hbWUtYXQtZ21haWwoZG90KWNvbQo= | base64 -d>
+
+pkgname=ttf-antonio
+pkgver=1.01
+pkgrel=1
+pkgdesc="A 'refined' version of the Anton font, a large typeface designed for banners and headlines"
+url="https://github.com/vernnobile/antonioFont"
+arch=(any)
+license=('OFL')
+makedepends=('git')
+source=("git+${url}#commit=4b3e07ab5647a613931153a09067a785f54b980a")
+sha256sums=('SKIP')
+
+_ttf_files_paths=("Regular/Antonio-Regular.ttf"
+"Light/Antonio-Light.ttf"
+"Bold/Antonio-Bold.ttf")
+
+package() {
+ cd "$srcdir/antonioFont"
+
+ install -d "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+
+ for ttf_file in "${_ttf_files_paths[@]}"; do
+ install -m644 "$ttf_file" "$pkgdir/usr/share/fonts/${pkgname%-fonts}"
+ done
+}