summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2018-12-09 15:41:20 -0700
committerAinola2018-12-09 15:41:20 -0700
commit02409bdb4e370e22bfc82f8cdb742753068705d8 (patch)
tree4d6a3a80b0650cd54932efadf172a620cb7f04ee /PKGBUILD
parent60dd178e49b3d892400332c1ac60a1515fad1ed5 (diff)
downloadaur-ttf-lato.tar.gz
PKGBUILD cleanups
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 11 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 608d519cea38..f5a9935b0796 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,19 @@
-# Maintainer: Thomas Weißschuh <thomas t-8ch de>
+# Maintainer: Ainola <brett@archlinux.org>
+# Contributor: Thomas Weißschuh
pkgname=ttf-lato
pkgver=2.015
-pkgrel=1
-pkgdesc='a sanserif type­face family'
-url="http://www.latofonts.com/lato-free-fonts/"
+pkgrel=2
+pkgdesc='A sanserif typeface family bearing the Polish name of "Summer"'
+url="https://www.latofonts.com/lato-free-fonts/"
license=('custom:OFL')
arch=('any')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-font-utils')
-source=("${pkgname}-${pkgver}::http://www.latofonts.com/download/Lato2OFL.zip"
- 'install')
-
-install=install
+source=("$pkgname-$pkgver.zip::https://www.latofonts.com/download/Lato2OFL.zip")
+sha256sums=('42b54e96c07e299d967fc3227c7bd63a20d6cfb1dc8fd6dae83628091e20a5b8')
package() {
- cd "${srcdir}/Lato2OFL"
- install -dm755 "${pkgdir}"/usr/share/fonts/TTF
- install -m644 *.ttf "${pkgdir}"/usr/share/fonts/TTF
-
- install -Dm644 OFL.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 README.txt "${pkgdir}/usr/share/doc/${pkgname}/README.txt"
- install -dm755 "${pkgdir}/usr/share/doc/${pkgname}/"
+ cd Lato2OFL
+ install -Dm644 *.ttf -t "$pkgdir/usr/share/fonts/TTF/"
+ install -Dm644 OFL.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.txt -t "$pkgdir/usr/share/doc/$pkgname/"
}
-
-sha256sums=('42b54e96c07e299d967fc3227c7bd63a20d6cfb1dc8fd6dae83628091e20a5b8'
- 'c98e5a09e552c01b479c22aafa101ea3e3237d3727fcad4629730762bdf4afa1')