summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShadowKyogre2021-03-06 13:11:44 -0800
committerShadowKyogre2021-03-06 13:16:11 -0800
commit3ef464f21c78d08c089a0d9f0cb6cbd57cd6f8d0 (patch)
treebfbf8a1ad7d96e4ffe348894da081148f86bc0b3 /PKGBUILD
parenta2ceed6f902a5e84c6925b255ed174869984e7f0 (diff)
downloadaur-ttf-totem.tar.gz
Update source to GDrive upstream
Also remove post install hooks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6792f79d37c..93d9f5541216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
# Maintainer: markzz <mark dot weiman at markzz dot com>
# Contributor: ShadowKyogre <shadowkyogre@aim.com>
+_gdrive_id=1KofbXUBUo_ue22BfiGR26wDU98eO6Y1c
pkgname=ttf-totem
pkgver=1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Totem is a free font. Feel free to use it for personal and commercial."
arch=('any')
url="https://www.behance.net/gallery/16490287/TOTEM-Free-Typeface"
license=('custom')
-#makedepends=('unzip')
-depends=('fontconfig' 'xorg-fonts-encodings' 'xorg-mkfontscale' 'xorg-mkfontdir')
-source=("https://www.dropbox.com/s/e02a0xkoqzjb2h8/TOTEM.zip")
-md5sums=('2873718a9127ca5a5d8c83c37d15a7e0')
-install=$pkgname.install
+makedepends=('unrar')
+depends=()
+source=("ttf-totem-${pkgver}-${pkgrel}.rar::https://docs.google.com/uc?export=download&id=${_gdrive_id}")
+noextract=("ttf-totem-${pkgver}-${pkgrel}.rar")
+
+prepare() {
+ cd "${srcdir}"
+ unrar e "${srcdir}/ttf-totem-${pkgver}-${pkgrel}.rar"
+}
package() {
install -dm755 "$pkgdir/usr/share/fonts/TTF"
@@ -23,3 +28,4 @@ package() {
}
# vim:set ts=2 sw=2 et:
+sha256sums=('d245930aea11f167414378709f16ec400b0b0e4337dade1317d84379ff4c6783')