summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAtticFinder655362022-11-11 17:37:21 +1100
committerAtticFinder655362022-11-11 17:37:21 +1100
commit22ed497c6f0c9058254b7a0d207b8ec840ce4149 (patch)
treeff14240c8f5eb62d6f34e04b6e7d3604fe43a259 /PKGBUILD
parent623458b0d13a5ba39b557501a69952ff8c9e427f (diff)
downloadaur-ttf-twemoji-color-git.tar.gz
Download scfbuild in the sources array rather than in prepare()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f7ecd867e73..b04728cbd200 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,10 @@ epoch=1
pkgdesc="A color and B&W emoji SVG-in-OpenType font by Twitter with support for ZWJ, skin tone modifiers and country flags (git)"
url="https://github.com/eosrei/twemoji-color-font"
license=('custom:CCPL:by-4.0' 'MIT')
-source=('git+https://github.com/eosrei/twemoji-color-font.git')
-b2sums=('SKIP')
+source=('git+https://github.com/eosrei/twemoji-color-font.git'
+ 'git+https://github.com/13rac1/scfbuild.git')
+b2sums=('SKIP'
+ 'SKIP')
makedepends=('git' 'inkscape' 'imagemagick' 'potrace' 'python-fonttools' 'fontforge' 'svgo' 'nodejs' 'python-yaml')
arch=('any')
replaces=('twemoji-color-font')
@@ -23,7 +25,7 @@ pkgver() {
prepare(){
cd "${_gitname}"
- git clone https://github.com/13rac1/scfbuild.git SCFBuild
+ ln -s "${srcdir}"/scfbuild SCFBuild
sed -i 's/package: regular-package linux-package deb-package macos-package windows-package/package: linux-package/' Makefile
}