summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2017-07-29 14:39:05 +0200
committerChristopher Arndt2017-07-29 14:39:05 +0200
commita088db4811972120f0cbed83ead2cf2c2958b580 (patch)
tree99844f5f604a807a5dd802c4bea681bab49ef722 /PKGBUILD
parent18a5252f28d73243529c9cf2c70cba4c3bdf2832 (diff)
downloadaur-tunefish4-vst-bin.tar.gz
New upstream version; no i686 binary provided anymore
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ff686827e8f..b3cee7712073 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,25 @@
_pkgname=tunefish4
pkgname="${_pkgname}-vst-bin"
-pkgver=4.0.1
+pkgver=4.1.0
pkgrel=1
pkgdesc="An additive wavetable-based synthesizer VST plugin"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.tunefish-synth.com/"
# See https://github.com/paynebc/tunefish/blob/master/COPYING
license=("GPL3")
groups=('vst-plugins')
# glib2 and graphite are included, even if namcap thinks the dependencies are
# already satisfied, but this is caused by the cyclic dependency
-# freetype <-> harbuzz
+# freetype <-> harfbuzz
depends=('alsa-lib' 'glib2' 'freetype2' 'graphite' 'mesa')
source=()
-source_i686=("http://www.tunefish-synth.com/downloads/tunefish-v${pkgver}-linux32-vst24.tar.gz")
source_x86_64=("http://www.tunefish-synth.com/downloads/tunefish-v${pkgver}-linux64-vst24.tar.gz")
-sha256sums_i686=('3f4e4c336db48ce9cf922704bb38f82960eef85dc9c0a7a989d5032a1902c7e4')
-sha256sums_x86_64=('9595aad67134631700aec4c4f2c5ae255d025493b3432ca4148b8fafbd9a5d84')
+sha256sums_x86_64=('4959046c766441c527455bb43fa9a4ca702f76263355751cefe8c5ba325b4656')
package() {
install -dm755 "${pkgdir}/usr/lib/vst/tf4programs"
- install -m755 "${srcdir}/${_pkgname}.so" "${pkgdir}/usr/lib/vst"
+ install -m755 "${srcdir}/Tunefish4.so" "${pkgdir}/usr/lib/vst"
install -m644 "${srcdir}/tf4programs/"* "${pkgdir}/usr/lib/vst/tf4programs"
}