summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreugene2024-01-30 16:03:49 +0000
committereugene2024-01-30 16:03:49 +0000
commita51d7baeb92d8f1a89ccac6b6940b9f94c96069a (patch)
tree7fe641a7d534ddd8d6d190a4f065ed6072ea7214 /PKGBUILD
parentb53f7e4c86a4b0740038f5397ff0eca8122d5d94 (diff)
downloadaur-tuxpaint-config.tar.gz
fix license and deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8955d2077c1..c997f3ea18be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,15 @@ pkgrel=1
pkgdesc='Tux Paint configuration tool'
arch=('x86_64')
url='https://www.tuxpaint.org/'
-license=('GPL')
-depends=('tuxpaint' 'fltk' 'libxft' 'libxext' 'libunibreak')
-options=('!makeflags')
+license=('GPL-2.0-only')
+depends=('fltk' 'fontconfig' 'gcc-libs' 'glibc' 'hicolor-icon-theme'
+ 'libpaper' 'libunibreak' 'pango')
+optdepends=('tuxpaint: ability to use tuxpaint provided fonts')
source=("https://downloads.sourceforge.net/sourceforge/tuxpaint/$pkgname-$pkgver.tar.gz")
sha256sums=('95d7502a1b29fbf0e157793e634197bf08a6b6ae3f604e2991d117d2fae70135')
build() {
- make -C "$pkgname-$pkgver" PREFIX=/usr
+ make -C "$pkgname-$pkgver" CFLAGS="$CFLAGS $LDFLAGS" PREFIX=/usr
}
package() {