summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorL.G. Sarmiento2022-07-01 15:43:19 +0200
committerL.G. Sarmiento2022-07-01 15:43:19 +0200
commit1f97aeb08320ac40cd4f6c1290fc9dd3a4e18b79 (patch)
treeb7dd3cb6ed38611a2cd1ce85d923216c2de0f4c7 /PKGBUILD
parent863c0916ec509af4f2d41a2efea38a4534334862 (diff)
downloadaur-tv.tar.gz
fixed format not a string literal and no format arguments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 973d45d49318..e61d107b1eb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,14 @@ options=('!emptydirs')
source=("https://web.archive.org/web/20110707105717/http://www.ikp.uni-koeln.de/src/${pkgname}-${pkgver}.tar.gz")
md5sums=('5b739a811abe604cbe4160e4402796dc')
+prepare(){
+ # ALC_WRITE
+ sed -i '180 s/(alc_fp, str)/(alc_fp, "%s", str)/g' ${srcdir}/${pkgname}-${pkgver}/lib/tv/vsAlloc.c
+
+ # ALC_ERROR
+ sed -i '33 s/fprintf(alc_fp, AlcError(AlcErrNo))/fprintf(alc_fp, "%s",AlcError(AlcErrNo))/g' ${srcdir}/${pkgname}-${pkgver}/lib/tv/vsAlloc.c
+}
+
build() {
cd ${srcdir}/${pkgname}-${pkgver}/doc/tex/Manual
make all html