summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbinex-dsk2020-09-19 18:43:36 -0400
committerbinex-dsk2020-09-19 18:43:36 -0400
commitd2c4216cc7f7b969ca2ca5aa363caffb603310db (patch)
tree33366d31455d46a5c6088236c6ea47e87ca35ede /PKGBUILD
parent6da7383cc7c9d1a7b5514dd5a460713c7eccc6a9 (diff)
downloadaur-twombit.tar.gz
fixed build errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eab77d49b867..2318a8fb18ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
# Maintainer: Carson Rueter <roachh@protonmail.com>
+# Contributor: Carson Rueter <roachh@protonmail.com>
# Contributor: Thomas Ascher <thomas.ascher@gmx.at>
+
pkgname=twombit
_installdir=/usr/share/$pkgname
pkgrel=1
@@ -16,18 +18,24 @@ depends=('freeglut'
source=("https://sourceforge.net/projects/$pkgname/files/v%20$pkgver/${pkgname}_src.zip"
"nonerror_type_fix.patch"
"settings_path_fix.patch"
+ "build_fix.patch"
+ "build_fix2.patch"
"twombit.desktop"
"twombit.png")
sha256sums=('c5fb1651176b75545445fbdec90739f0c4ef8550f628f814f240b4dda1eab624'
'cbcdfb10f3ca9d6b12cccf479dbf67b48f0b441600f0fa77795e7842aebc43fd'
'171aa5601fbdbb28340a72e2de520b6bb7c8d021df9bdc8ad1379916d961be3f'
+ '572553a29312c3255a669540788f902c7d8d6e1cdd2d0c386ac018ff54c836f0'
+ '74b489efb444ae667f0fd2902d5bb7e0ac1a43f8830f74f8952cbd055be713b6'
'70202b3113b4b61ddd504a99493ca01f829a896ffac7ec686d344e0fbce535b8'
'9988bbb328bc546ba21655e695049edc2112bb00f683a565aa237a0fbbf220de')
build() {
- cd "src"
- patch --binary -Np1 -i "../nonerror_type_fix.patch"
- patch --binary --forward -Np1 -i "../settings_path_fix.patch"
+ cd src
+ patch --binary -Np1 -i ../nonerror_type_fix.patch
+ patch --binary -Np1 -i ../settings_path_fix.patch
+ patch --binary -Np1 -i ../build_fix.patch
+ patch --binary -Np1 -i ../build_fix2.patch
qmake-qt4 TwoMbit.pro
make -j $(cat /proc/cpuinfo | grep processor | wc -l)
}