summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authora8212023-11-07 10:44:09 +0100
committera8212023-11-07 10:44:09 +0100
commit6616face14d47edf13feb21eccb647ce9734c057 (patch)
treefd859b69675e9b19940860b4e58982fad54726b2 /PKGBUILD
parent90d5e93467451a474ad89e33cd94996d49ce7de2 (diff)
downloadaur-txt2tags-git.tar.gz
PEP 517
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e38caa75d13..0b0eaa193b86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: a821
pkgname=txt2tags-git
-pkgver=3.8.r0.gf570b43
+pkgver=3.9.r0.gbc7f2c4
pkgrel=1
pkgdesc="A text formatting and conversion tool"
arch=('any')
@@ -10,7 +10,7 @@ license=('GPL2')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
depends=('python')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel')
source=("git+https://github.com/txt2tags/txt2tags.git#branch=v3")
sha256sums=('SKIP')
@@ -21,12 +21,12 @@ pkgver() {
build() {
cd "${pkgname%-git}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${pkgname%-git}"
- python setup.py install --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim: set ts=4 sw=4 et: