summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbigeagle2015-07-04 14:11:27 +0800
committerbigeagle2015-07-04 14:11:27 +0800
commitcb4f203b0204e7a01a0bf57fa33f8c9fbd2ce51c (patch)
treed34bf7109f103095532684280b1d40ef93b99045 /PKGBUILD
downloadaur-udevedu-git.tar.gz
initial build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb168fb8dadb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Justin Wong <i(at)bigeagle(dot)me>
+
+pkgname=udevedu-git
+_pkgname=udevedu
+pkgver=0.r13.26a521f
+pkgrel=1
+pkgdesc="Udev event dispatcher for unprivileged users"
+arch=('i686' 'x86_64')
+url="https://github.com/xiaq/udevedu"
+license=('GPL')
+depends=('python-pyudev')
+makedepends=('git')
+sha256sums=('SKIP')
+source=("${pkgname}::git+https://github.com/xiaq/${_pkgname}.git")
+
+pkgver() {
+ cd "${pkgname}"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$srcdir/${pkgname}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}