summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Cohen2022-03-12 18:02:45 -0600
committerDavid Cohen2022-03-12 18:22:11 -0600
commit34f3a9fa10c859df005ada2c0aafa6e20988ac31 (patch)
tree7947b49a517992170e63b56aa755d8e639339873 /PKGBUILD
downloadaur-ukpdate-git.tar.gz
Initial commit
Signed-off-by: David Cohen <dacohen@pm.me>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..781ec318dc87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: David Cohen <dacohen@pm.me>
+# Contributor: Andrey Vihrov <andrey.vihrov at gmail.com>
+
+pkgname=ukpdate-git
+pkgver=0.r116.7350200
+pkgrel=1
+pkgdesc="UEFI Unified Kernel Image manager tool"
+arch=('any')
+url="https://github.com/osimarr/ukpdate"
+license=('GPL3')
+install=ukpdate.install
+depends=('bash>=4.4' 'systemd' 'binutils' 'sbsigntools')
+makedepends=('git')
+conflicts=('sbupdate' 'ukpdate')
+provides=('ukpdate')
+backup=('etc/ukpdate.conf')
+source=("git+https://github.com/osimarr/ukpdate.git?signed")
+validpgpkeys=('96F281C741F4F2693E96885BF6532C30466E8B3E',
+ '9CE1B36F586373C8A5DD89E447EDFD24F02ADC29')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ukpdate
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ukpdate
+ make DESTDIR="${pkgdir}" DOCDIR="/usr/share/doc/${pkgname}" install
+}
+
+# vim:set ts=2 sw=2 et: