summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlbin Larsson2021-07-31 14:37:25 +0200
committerAlbin Larsson2021-07-31 14:56:16 +0200
commit9baa92b892b804139d916e1d4fcd53a4ca4743d0 (patch)
treeb7282ad1711699455f4fbcc7ba3fcf234297c39c /PKGBUILD
parent8ff68f029e0de5bd70134ada88e9cb86d0779516 (diff)
downloadaur-ulauncher-revived-git.tar.gz
Update to use the new setup.py
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 2 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 034d01b98167..02c565dceaa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ license=('GPL3')
depends=('gobject-introspection-runtime' 'libkeybinder3' 'gtk3' 'webkit2gtk' 'libnotify'
'gdk-pixbuf2' 'python-dbus' 'python-levenshtein' 'python-pyinotify'
'python-websocket-client' 'python-pyxdg' 'python-gobject' 'python-cairo')
-makedepends=('git' 'yarn' 'python-setuptools' 'python-distutils-extra')
+makedepends=('git' 'yarn' 'python-setuptools')
checkdepends=('desktop-file-utils')
optdepends=('libappindicator-gtk3: tray icon' 'wmctrl: fix window focus on Wayland')
install="ulauncher.install"
@@ -25,34 +25,17 @@ sha256sums=('SKIP')
pkgver() {
cd ulauncher
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd ulauncher
- sed -i "s/%VERSION%/${pkgver%.*.*}/g" setup.py
- find -iname "*.py" | xargs sed -i 's=\(^#! */usr/bin.*\)python3 *$=\1python='
+ python setup.py --version | tr "-" "~"
}
build() {
cd ulauncher
python setup.py build
- ./ul build-preferences
-}
-
-check() {
- cd ulauncher
- desktop-file-validate "build/share/applications/ulauncher.desktop"
}
package() {
cd ulauncher
-
- install -Dm644 "build/share/applications/ulauncher.desktop" -t \
- "$pkgdir/usr/share/applications"
-
export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 "contrib/systemd/ulauncher.service" -t "$pkgdir/usr/lib/systemd/user"
find $pkgdir -type d -name __pycache__ | xargs rm -rf
}