summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRomain Beucher2021-02-12 09:24:48 +1100
committerRomain Beucher2021-02-12 09:26:33 +1100
commit385d2c12d837196bf6bff6e8e359a8def3017493 (patch)
treeba36e88d56715e227647ef1ecdeb61b8a1515459 /PKGBUILD
parentfc56802da2098606e502768919cae1c3debde4c1 (diff)
downloadaur-underworld2-git.tar.gz
updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23d2eab46fdb..49b34e2eb1eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,19 @@ url="http://underworldcode.org"
license=('GPL')
depends=('openmpi' 'hdf5-openmpi' 'petsc' 'python-matplotlib' 'python-numpy' 'python-mpi4py'
'python-h5py-openmpi' 'swig' )
-makedepends=('git' 'gcc-fortran' 'swig' 'scons')
+makedepends=('git' 'gcc-fortran' 'swig' 'scons' 'python-setuptools')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('underworld2::git+https://github.com/underworldcode/underworld2#branch=development')
noextract=()
md5sums=('SKIP')
+build() {
+ cd ${pkgname%-git}
+ python setup.py build
+}
+
package() {
- cd ${pkgname%-git}
- pip install --root="${pkgdir}" . -vvv
+ cd ${pkgname%-git}
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}