summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcameel2018-01-21 00:23:05 +0100
committercameel2018-01-21 00:23:05 +0100
commit9f1cbc503a85b284992b6099920f7cf88f97d7fa (patch)
treebea5d1e95ad6d201d2f15afd16ee7aa7d41af9e2 /PKGBUILD
downloadaur-unimatrix-git.tar.gz
Add PKGBUILD
- No official release yet so pkgver is based on the commit number
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..94aa05538cd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Kamil ƚliwak <cameel2/at/gmail/com>
+
+pkgname=unimatrix-git
+pkgver=r30.3692561
+pkgrel=1
+pkgdesc='Python script to simulate the display from "The Matrix" in terminal. Uses half-width katakana unicode characters by default, but can use custom character sets.'
+arch=('any')
+url="https://github.com/will8211/unimatrix"
+license=('GPL3')
+depends=('python')
+makedepends=('git')
+provides=('unimatrix')
+conflicts=('unimatrix')
+source=("$pkgname"::git+${url}.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+
+ # TODO: Right now there are no tags in the git repo.
+ # Change the command below to use tags when the first official version gets released.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+
+ mkdir --parents "${pkgdir}/usr/bin/"
+ install --mode 755 unimatrix.py "${pkgdir}/usr/bin/unimatrix.py"
+ ln --symbolic /usr/bin/unimatrix.py "${pkgdir}/usr/bin/unimatrix"
+}