summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictrid2022-04-28 18:12:54 +0800
committerVictrid2022-04-28 18:15:06 +0800
commita120f86b988e38ba6934aba93934b9f41dce751c (patch)
tree074be31175d05bb38298061b772b8133999dbe82 /PKGBUILD
downloadaur-unityhub-cn.tar.gz
Init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..085b6e644d10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Weihao Jiang <weihau.chiang#gmail.com>
+
+pkgname=unityhub-cn
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="The Unity Hub is a standalone application that streamlines the way you find, download, and manage your Unity Projects and installations. (China localized version)"
+url="https://unity.cn/"
+arch=('x86_64')
+license=('custom')
+depends=('nss' 'gtk3')
+optdepends=(
+ 'libappindicator-gtk3: The DEB says this an optional dependency'
+ 'gconf: Used by old editors'
+ 'cpio: used for Android build support'
+)
+source=(
+ "$pkgname-$pkgver.deb::https://public-cdn.cloud.unitychina.cn/hub/prod/UnityHubSetup.deb"
+ 'license.txt'
+)
+sha256sums=('2953526a671543af613998d50808df204c5fbf70685564e208f36f663679d34a'
+ 'f0eb3a4bb148bb7f426e4f5b97e891265ac487710cbcba9282518537c7b5d833')
+provides=('unityhub')
+conflicts=('unityhub')
+
+OPTIONS=(!strip)
+
+package() {
+ tar -xf 'data.tar.bz2' -C "$pkgdir/"
+ mkdir -p "$pkgdir/usr/bin"
+ ln -sf '/opt/unityhub/unityhub' "$pkgdir/usr/bin/unityhub"
+
+ install -Dm644 "$srcdir/license.txt" "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}