summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann2021-05-13 16:24:24 +0200
committerAndreas Baumann2021-05-13 16:24:24 +0200
commit4f7dcaef8da078425d95afe66bb562331650ab06 (patch)
tree46417070e17d71fe4952a26f1c88b7816c5cec2f /PKGBUILD
downloadaur-vala-bootstrap.tar.gz
added initial version 0.16.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40aceda3d87f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=vala-bootstrap
+pkgver=0.16.1
+pkgrel=1
+pkgdesc='Bootstrapping Compiler for the GObject type system'
+url='https://wiki.gnome.org/Projects/Vala'
+arch=(i486 i686 pentium4 x86_64)
+license=(LGPL)
+depends=()
+makedepends=(git)
+provides=(vala)
+conflicts=(vala)
+_commit=b2beeacc # corresponds to 0.16.1
+source=("git+https://gitlab.gnome.org/Archive/vala-bootstrap.git#commit=$_commit")
+sha256sums=('SKIP')
+
+prepare() {
+ cd $pkgname
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr --disable-build-from-vala
+ make
+}
+
+check() {
+ cd $pkgname
+# tests are horribly broken
+# make check
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+}