summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-02-09 17:08:11 +0100
committersL1pKn072022-02-09 17:08:11 +0100
commit514b734e4b327df355a40053c99462b2ed8bb01f (patch)
tree23d317beba57e5a6f94d474899a1d37ad750bb7d /PKGBUILD
parent1b2504f80950200d30e4ccb9d7658d30e4051d50 (diff)
downloadaur-vapoursynth-plugin-reduceflicker-git.tar.gz
bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 18 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 393f035774e6..98bed59396c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,43 +2,41 @@
_plug=reduceflicker
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r2.8766391
+pkgver=0.0.0.VS.3.ge37d9b2
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
-url='https://github.com/VFR-maniac/VapourSynth-ReduceFlicker'
-license=('GPL')
-depends=('vapoursynth'
- 'fftw'
- )
-makedepends=('git')
+url='https://github.com/AmusementClub/ReduceFlicker'
+license=('LGPL')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/VFR-maniac/VapourSynth-ReduceFlicker.git")
+source=("${_plug}::git+https://github.com/AmusementClub/ReduceFlicker.git")
sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
- #echo "$(git describe --long --tags| tr - .)"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ echo "$(git describe --long --tags| tr - .)"
}
prepare() {
- rm -fr "${_plug}/VapourSynth.h"
+ mkdir -p build
}
build() {
- cd "${_plug}"
- ./configure \
- --prefix=/usr \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
- --extra-ldflags="${LDFLAGS}"
+ cd build
+ arch-meson "../${_plug}/vapoursynth" \
+ --libdir /usr/lib/vapoursynth
- make
+ ninja
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
-# install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/vapoursynth/readme.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/vapoursynth/LICENSE.LGPLv2.1" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}