summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOSAMC2022-07-23 15:21:41 +0000
committerFlorian Hülsmann2022-07-23 15:21:41 +0000
commit3a24bffb0ffc7549b2c4b2d798a75f493dfa2671 (patch)
tree7aa4a9da4eb30e0fc6c83340fd402b81f7656eba /PKGBUILD
downloadaur-vcvrack-alikins.tar.gz
package more vcvrack plugins (#101)
* package more vcvrack plugins * vcvrack-freesurface: devendor static libsamplerate * AUR and nvchecker * Make package descriptions more explicit * link libsamplerate in vcvrack-freesurface
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21889666e9c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Florian Hülsmann <fh@cbix.de>
+
+_slug=Alikins
+_name=Alikins-rack-plugins
+pkgname=vcvrack-alikins
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='Alikins VCV Rack modules'
+arch=(x86_64 aarch64)
+url='https://github.com/alikins/Alikins-rack-plugins'
+license=(GPL3)
+groups=(proaudio vcvrack-plugins)
+depends=(gcc-libs vcvrack)
+makedepends=(simde zstd)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/alikins/$_name/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('8e8f6e776205ecb11b268760b42e5eea08d92ac2c50f994abd732cfd92ecc877')
+
+build() {
+ cd $_name-$pkgver
+ make SLUG=$_slug VERSION=$pkgver RACK_DIR=/usr/share/vcvrack dist
+}
+
+package() {
+ cd $_name-$pkgver
+ install -d "$pkgdir"/usr/lib/vcvrack/plugins
+ cp -va dist/$_slug -t "$pkgdir"/usr/lib/vcvrack/plugins
+ # remove common license
+ rm "$pkgdir"/usr/lib/vcvrack/plugins/$_slug/LICENSE.txt
+}