summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPopolon2021-04-18 11:44:48 +0200
committerPopolon2021-04-18 11:44:48 +0200
commit568ba70ed9a563714037a93a58acc1a83c22d13b (patch)
treeff2eb362adf307e0323640d6ff0cb892e8f86031 /PKGBUILD
parent6c9b308ce1e1e606971e6f4b2bd2ffde7ea41afa (diff)
downloadaur-vcvrack-audible-instruments-git.tar.gz
made audibleinstrument compilable again, mixing vcvrack-eserie-git PKGBUILD function with this one, could probably be optimized. In my case, need to "ln -s /opt/vcvrack/plugins/* ~/.Rack/plugins-v1/", to make it work, next step: have all the plugin isntalled the same way, unziped in /opt/vcvrack/plugins/ and then change vcvrack behavior to read it
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e665997ed42..0d0613307d80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
-# Maintainer: Miroslav Koškár <http://mkoskar.com/>
+# Maintainer: Popolon <popolon@popolon.org>
+# Contributor: Miroslav Koškár <http://mkoskar.com/>
_basename='vcvrack'
_plugname='AudibleInstruments'
pkgname='vcvrack-audible-instruments-git'
-pkgver=0.4.0.r27.g66936b0
-pkgrel=1
+pkgver=1.4.0.r6.g8c7fd24
+pkgrel=2
pkgdesc="Mutable Instruments' VCV modules"
url='https://github.com/VCVRack/AudibleInstruments'
license=(BSD)
@@ -78,8 +79,16 @@ prepare() {
}
build() {
- cd "$_basename/plugins/$_plugname"
- make
+ # define RACK_DIR, so Makefile snippets can be found
+ export RACK_DIR="/usr/share/vcvrack"
+ # define FLAGS, so headers can be included
+ export FLAGS="-I/usr/include/vcvrack -I/usr/include/vcvrack/dep"
+ # exporting LDFLAGS for libsamplerate, as the Delay module requires it
+ export LDFLAGS="$(pkg-config --libs samplerate) ${LDFLAGS}"
+ cd "$_basename/plugins/$_plugname"
+
+ USE_SYSTEM_LIBS=true make
+ USE_SYSTEM_LIBS=true make dist
}
package() {
@@ -87,5 +96,5 @@ package() {
install -D -m644 -t "$pkgdir/usr/share/licenses/$_basename/$_plugname" LICENSE*
install -d "$pkgdir/opt/$_basename/plugins/$_plugname"
cp -dr --preserve=mode -t "$pkgdir/opt/$_basename/plugins/$_plugname" \
- res plugin.so
+ res plugin.so plugin.json
}