summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLunarEclipse2024-01-31 09:45:30 +0100
committerLunarEclipse2024-01-31 09:45:30 +0100
commit46b414cca02cab327914c632c61e7b54993e5b03 (patch)
treeb4206991b35526a042e49e4f27ae8bbc06033aca /PKGBUILD
parentf602bb0656350bb2e4def9fe2d40c5592aec6791 (diff)
downloadaur-veloren-git.tar.gz
Fixed pkgver, a typo, and changed the url to be more useful
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 197f601aa654..813ebe3fa068 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
export GIT_LFS_SKIP_SMUDGE=1
pkgname=veloren-git
-pkgver=0.13.0.r37.525866816
+pkgver=0.15.0.r961.gb744f66733
pkgrel=1
-pkgdesc="The developement version of an open-world, open-source multiplayer voxel RPG"
+pkgdesc="The development version of an open-world, open-source multiplayer voxel RPG"
arch=('x86_64' 'i686')
-url='https://veloren.net/'
+url='https://gitlab.com/veloren/veloren'
license=('GPL3')
options=('!strip') # This makes debugging issues easier sometimes, comment out if small package size is needed
depends=('alsa-lib' 'glslang' 'libxkbcommon-x11' 'pulseaudio-alsa' 'vulkan-icd-loader')
@@ -20,7 +20,7 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/v//'
+ git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
prepare() {