summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHenry-Joseph Audéoud2022-03-07 11:25:24 +0100
committerHenry-Joseph Audéoud2022-03-07 11:25:24 +0100
commit55bfc858ab007c3ffe31ab3b0cc47ea8e2616ec7 (patch)
tree613d2f5fd27da21fc0cbe4b47d1899e89ecb3d69 /PKGBUILD
downloadaur-vim-detectspelllang.tar.gz
Initial upload: vim-detectspelllang 2.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bde43bde708
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Henry-Joseph Audéoud <h.audeoud+aur@gmail.com>
+
+pkgname=vim-detectspelllang
+_pkgname="${pkgname%vim-}"
+pkgver=2.2
+pkgrel=1
+pkgdesc="Make Vim autodetect the spellcheck language"
+arch=(any)
+url="https://github.com/Konfekt/${pkgname}"
+license=(unknown)
+depends=(vim-plugin-runtime)
+groups=(vim-plugins)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}/vim-DetectSpellLang-${pkgver}" # Case matters!
+ _installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ for file in autoload/*.vim doc/*.txt plugin/*.vim; do
+ install -Dm644 "$file" "${_installpath}/${file}"
+ done
+}