summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkaptoxic2018-05-31 15:33:52 -0400
committerkaptoxic2018-05-31 15:33:52 -0400
commitff4faf25a9530934811c5a001383eca93dea1d2b (patch)
tree3f1e99b2a3f1ff315554ad647dfb26bbf7186601 /PKGBUILD
parentc367eafa018cd1f1b6874eb7ee422e1a254293c0 (diff)
downloadaur-vim-gnome.tar.gz
Update man page removal
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 617a133fda44..e17fb1c0892e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,16 +57,17 @@ build() {
package() {
cd vim-$pkgver
- make -j1 VIMRCLOC=/etc DESTDIR=${pkgdir} install
+
+ make -j1 VIMRCLOC=/etc DESTDIR="${pkgdir}" install
# provided by (n)vi in core
rm "${pkgdir}"/usr/bin/{ex,view}
- # not deleted: rview xxd vimtutor
- find ${pkgdir}/usr/share/man -type d -name 'man1' 2>/dev/null | \
+ # delete some manpages
+ find "${pkgdir}"/usr/share/man -type d -name 'man1' 2>/dev/null | \
while read _mandir; do
- cd ${_mandir}
- rm -f ex.1 view.1 # provided by (n)vi, not deleting vimtutor.1 xxd.1
+ cd "${_mandir}"
+ rm -f ex.1 view.1 # provided by (n)vi
done
# need to remove since this is provided by vim-runtime